Skip to main content

Blogging from snowy Finland

First post on my first blog... Lots to say but can't deside what to say so I decided to start by a introduction of myself before we get into business.

I do software development for a living and that also happens to be a hobby of mine, what a nice coincidence. I work as a IT-consultant and I'm loving it most of the time. I get to see a lot of different environments and solutions but... there's always a but, I also see a lot that could be improved. With improvement I mean cleaner, simpler and easier to understand solutions.

I do most of my programming with Java, but I've had some experience with HTML, CSS, PHP etc. solutions in my past and in the last two years I've done some development with Groovy and modern JavaScript libraries.
Various relational databases have been part of my toolbox since I started web development with MS ASP and PHP over a decade ago. Recently I've also done development with NoSQL databases as a backend instead of RDBMS.
I haven't given a proper try to functional programming languages yet but I'll be doing that in the future first I have to do few other things.

Theme of this blog is going to be various aspects of my experiences and thoughts of software development. Perhaps even some actual code... or maybe I'll just put that in github.

Comments

Popular posts from this blog

Simple code: Immutability

Immutability is a special thing that in my mind deserves a short explanation and praise. If you're familiar with functional programming you surely recognice the concept of immutability because it's a key ingredient of the paradigm. In the world of object oriented programming it's not as used and as easy to use approach but there are ways to incorporate immutability to parts of the code and I strongly suggest you to do so. Quick intro to immutablity The basic idea of immutability is unchangeable data.  Lets take a example. We have a need to modify a object's property but because the object is immutable we can't just change value but instead we make a copy of the object and while making the copy we provide the new value for the copy. In code it looks something like this. val pencil = Product(name = "Pencil", category = "Office supply") val blackMarker = pencil.copy(name = "Black marker") The same idea can be applied in functions and metho

Simple code: Contracts

Code works around contracts and contracts should be carefully thought and crafted. What are contracts A High abstraction level of contracts for code are API's. They define a interface that is basically a contract that the producer and consumer of the API agree to use to communicate with each other. Two common forms of API's are libraries that are used in code and external API's  that are used via HTTP, RPC etc. When thinking in a bit deeper contracts consist firstly of functions, methods or external endpoints and secondly of data, more precisely on data models and data types within the models.   Defining contracts Contracts should always be defined with careful thought. I've come accross few times to someone saying that "this is for intenal use only so it doesn't need to defined and/or documented as thoughtfully as a public API would be" but I disagree with that. The same care should be be given to internal and external contracts because the contracts are

Simple code: Functions and methods

What makes a good function or method? I don't think it's a single thing but a combination of things where each is significant. If one the things is flawed it affects to all others and the whole function is flawed. So what are those "things"? Have a meaningful name Function should have a name that describes it's purpose or functionality. When a function has a meaningful name it's easy to read and understand what's it's purpose. Let's take a example. If function's purpose is to find a customer by it's id a good name could be findCustomerById(id: String) or it could just as well be just  findCustomer(id: String) because the function signature implies that the customer is found by it's id the word find also implies that the customer might be found or it might not be found. If the function's name would be changed to getCustomer(id: String) it's meaning changes because now it implies that there's no fallback, the customer is e